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 1 Introduction

The Flymaster Designer is a free application allowing users to design and manage, the

screen layout of select Flymaster instruments.

An unlimited number of  layouts can be created, each having up to sixteen different

display pages. The Flymaster Designer is also used to upload the created layouts to the

Flymaster  instruments.  Layouts  can be saved to  disk for  later  use and can easily  be

shared with other users.

 2 Getting the Designer

The  designer  installation  file  can  be  downloaded  from  Flymaster  website

(www.flymaster.net). On the web site the application is located in the “Downloads” section

of the “Flymaster Live” product page, download “FmDesigner.msi” for Windows operating

system, or FmDesigner.dmg for Mac OS X.

Double click on the downloaded file, then follow the installation steps on Windows, or

simply drag the app on the mounted dmg to the Applications folder of Mac OS.

 3 Overview

The  Flymaster  Designer  application  can  be  divided  into  4  distinct  areas:  Screen,

Elements, Toolbars and Thumbnails (see Figure 1).

• Screen area: Represents the 240X320 high resolution display of the Flymaster

instrument.  This  is  a  WYSIWYG  (what  you  see  is  what  you  get)  of  the

instrument's screen. 

• Elements Toolbox: This area contains all  the available elements that can be

used  to  define  the  layout.  Simply  dragging  and  dropping  elements  from  the

Elements Toolbox to the screen adds them to the Screen.
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• Thumbnails area: This area displays a miniature of all the pages of the layout,

referred to as thumbnails.  Clicking on a thumbnail  selects that page into the

Screen  area.  As  elements  are  added  to  the  screen(s)  the  thumbnails  will

automatically be updated.

• Toolbar: The “Toolbar” area contains several buttons which act like shortcuts to

several  functions.  Some examples can be the “Format”,  “Edit”,  or  “File”.  The

same functions can be accessed trough the designer menu options.

Figure 1- Flymaster Designer Overview
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 4 Defining the Instrument and Language

The Designer can be used with several Flymaster instruments, like the Live, NAV, or

Vario. Before, start using the designer you should define your instrument. 

In  order  to  select  the right  instrument  you should select  the “Preferences...”  option,

under the “Edit” menu. By doing it, a dialog box is opened which allows to define trough a

droplist the “Device”, and also the “Language”.

 5 Creating Layouts

When the designer is started an empty layout is automatically created. At any time the

layout can be saved using “Save” option, in the “File” menu bar.

A new Layout can be created using “New” option, in the “File” menu bar.

An existing layout can be opened using the “Open” option, in the “File” menu bar.

ATTENTION!! Sending a layout to the instrument will delete the existing layout on

the instrument.

 5.1 Understanding layouts 

A layout is in essence a set of  elements. Each element has a set of properties which

define what, where and how it is displayed on the instrument.  When looking at the

instrument's  screen  a  pilot's  eye  will  typically  become trained  to  the  positioning  of

different elements on the screen, so even when the instrument is capable of showing

several screens ideally several key elements should remain in the same place. With this

in  mind  the  Designer  follows a  key concept,  where  elements  have  a  property  that

defines on which pages it the element is visible, thus an element can be present on

several  pages  having  the  same characteristics.  This  concept  greatly  simplifies  and

speeds up the design process, and helps create consistent, easy to read layouts.
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 5.2 Elements

There are two classes of elements, namely: graphic elements and data field elements.

Adding an element to a layout is achieved by simply Draging & Droping it  from the

Elements toolbox onto the Screen area. When a new element is dropped onto the screen

it's  properties  dialog  box  automatically  pops  up,  allowing  for  immediate  adjustments,

selecting “Cancel” on the properties dialog at this moment will cancel the element Add.

Element properties will vary depending on the element type.

 5.2.1 Graphic Elements

Several  graphic  elements  are  available,  these  will  vary  depending  on  the  target

instrument and firmware version.

Figure 2 - Graphic Elements
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 5.2.2 Data field elements

Data field elements allow to display information generated by the instrument (see Figure

3). Examples are “Altitude”, Speed, or “Current Glide Ratio”.

Data fields can be resized. Resizing a data field element changes the bounding box

dimensions, but  not the font size.  The font size can be changed by setting the “Font”

attribute, there are three font size to choose from (Large – Normal – Tiny).

The data displayed and the available fields will vary depending on the instrument model.

A full explanation of available data fields can be found in the corresponding instrument

manual.

Figure 3 - Data Field Element

 5.3 Adding an Element

There are two ways to insert an element in the display area:

• Drag and Drop the element from the toolbox to the screen area.

• Click on the desired element in the Toolbox, the element will be placed on the

upper right corner of the screen area.

When the element is added a pop up window will display. This window allows changing

element properties, such as field type, size, visibility. Depending on the element type

certain properties cannot be changed.
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 5.4 Deleting an Element

Layout  elements  can  be  deleted  by  selecting  it  and  pushing  the  “Delete”  key,  or

navigating to the Edit menu and selecting delete. If several elements are selected all the

selected elements will be deleted. An element will also be automatically deleted when

the visibility property is removed from all pages, i.e an element that is not set to be

visible on any page cannot exist, thus is deleted.

 5.5 Changing Element Size and Position

Elements can also easily be manipulated using the mouse. To move an element: move

the mouse cursor over the element (the cursor will display an open hand); pushing the

left mouse button will change the cursor to a closed hand; moving the mouse now will

move the element. Moving the mouse cursor to the edge of an element will change the

cursor to a resize arrow, click and hold the mouse button then move the moving the

mouse will resize the element. Resizing an element will not change the font size. That

must be done using the element properties.

Figure 4 - Size edition

Size and position can be also be changed by editing the element's  properties (see

5.6.2).

 5.6 Changing Element Properties

Double  clicking  an  element  will  display  a  pop  up  window,  showing  the  element

properties. Depending on the element type  different properties may be changed.

Properties are organized in tabbed dialogs. The available tabs are:

• Data Field
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• Geometry

• Pages

The Data Field Tab is disabled when editing graphic elements properties.

 5.6.1 Data field tab

The Data Field tab is only available on data field elements. There are 6 configurable

properties in the Data field tab.

Figure 5- Data Field Tab

Field – Drop down list  selects  the data  shown on the element.  The available  data

depends on the target instrument (refer to the instrument manual for more information).

Font – Drop down list  selects  the  font  size.  Three  font  sizes  are  available:  Large,

Normal, Tiny. The Large font is only available for numeric data fields, since letters are not

defined is this font type.

Align – Drop down list defines text alignment in the data field bounding box. Options

available are: left, center, right.

Units – Drop down list selects if and how units should be displayed. If “right” is selected

the units will be display to the right of the data (ex. 50 km/h).
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Title – Check Box defines if a title should be displayed above the data. The title text is

always displayed in Tiny font.

Border – Check Box defines if a border should be drawn around the data field bounding

box.

 5.6.2 Geometry tab

The geometry tab defines the location and size of the element on the screen. All values

are in pixels.

Figure 6- Geometry tab

The X,  and Y,  are  the coordinates in  pixels,  of  the top left  vertex of  the data  field

element box. The origin of the coordinate system corresponds to the top-left corner of the

instrument screen. The maximum values of X, and Y, are respectively 240, and 320 pixels.

The Width, and Height, defines the dimensions of the data field element box in pixels.

If  an  the  defined  geometry  places  an  element  out  of  the  screen,  the  Designer

automatically readjusts the X and Y coordinates.
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 5.6.3 Pages tab

The “Pages Tab” defines on which pages an element is visible. When the user wants to

use  the same element,  with  the same properties,  in  different  pages  it  can  check  the

corresponding check box in the “pages tab”.

Please note that, an element visible in multiple pages is the same element in all the

pages. This means that, moving or changing properties of an element changes it on all the

pages that contain it.

Figure 7- Pages tab

 5.7 Alignment tools

The designer  provides a  set  of  tools  to facilitate  the alignment  of  elements.  All  the

alignment tools are shown under the format menu, and also on a toolbar.
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Figure 8- Alignment Toolbar

The alignment tools are only activated (highlighted)  when one or more elements are

selected.

Multiple elements can be selected by placing the mouse cursor on an area of the screen

where no element is present, so that the cursor is an arrow. Click and hold the left

mouse button then moving the mouse initiates a selection rectangle.  Releasing the

mouse  will  select  all  the  elements  that  intersect  the  selection  rectangle.  Multiple

elements can also be selected by holding the “Shift” key and clicking on each element.

If a previously selected element is reselected, by a selection rectangle, or if a selected

element is reselected, that element will become the reference element. The reference

element will be marked violet (see Figure 9). 

The reference element will cause alignments to referenced to it. For example when an

element  is  reference  selecting  a  Left  Align  will  cause  the  left  edge  of  all  selected

elements  to  align  with  the  left  edge  of  the  reference  element,  when  no  reference

element  exists  in  the  selection  that  same left  alignment  will  cause  all  the  selected

elements to align their left edges to the left edge of the left most element.

Figure 9- Reference Element

Each  alignment  tool  defines  different  alignment  rules.  The  thumbnails  are  self

explanatory. See Table 1 for a brief description.
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Tool Alignment reference defined No alignment reference defined

Aligns all the Element(s) regarding
the top edge of the reference one.

The same being the top most element the
reference.

Aligns all the Elements regarding
the bottom edge of the reference
one.

The same being the bottom most element the
reference.

Aligns all the Elements regarding
the Left edge of the reference one.

The same being the left most element the
reference.

Aligns all the Elements regarding
the right edge of the reference.

The same being the right most element the
reference.

Align the left edge of the non
reference element according the
axis which includes the right edge of
the reference element.

The same being the left most element the
reference.

Align the top edge of the non
reference element according the
axis which includes the bottom edge
of the reference element.

The same being the top most element the
reference.

Aligns all Elements vertical axes
according the reference element
vertical axis.

The same being the center element the
reference.

Aligns all Elements horizontal axes
according the reference element
horizontal axis.

The same being the center element the
reference.

Change the height of all Elements to
match the height of the reference
element.

The same being the highest element the
reference.

Change the width of all Elements to
match the width of the reference
element.

The same being the widest element the
reference.

Table 1 - Alignment Tools

 6 Page Properties and “Triggers”

Each of the 16 available pages has its own properties. Double clicking over the desire

page will open a dialog box similar to the one of Figure 10.
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Using the dialog box the user can set the page name, and disable the page by checking

the corresponding box. If a page is disabled then it is ignored when the user is scrolling

trough pages.

Figure 10- Page Properties Dialog Box

The most important property of a page is its “Trigger”. Pages can be automatic activated

during flight  by defining a  trigger  event  for  the  page.  In  this  way,  the  user  can  have

different pages according different flight contexts,  which can be automatically activated

(switched) if a certain condition is meet.

One good example is an airspace control page. In a airspace control page the user can

have the airspaces map, as also different airspaces related data fields (eg. Distance to

CTR). Additionally, the trigger “Airspace Warning” can be set to this page.

During flight the user can have any page active, for example a thermal page. However,

if an airspace limit is reached the device will automatic change the page to airspaces one.

Each device has its own trigger events. Please check your device user manual in order to

know more details about the available trigger events.

 7 Managing Layout Files

Layouts can be saved for future use. The Flymaster Designer will remember the name

of a previously opened layout,  saving will  replace it.  Using the “Save as” option allow

saving under a different name, thus creating a new file.

To open, or save, an layout file just go to “File” menu and select the corresponding
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option.

 8 Sending a Layout to the Instrument

Sending a layout to the instrument requires it to be switched on and connected to the

PC's  usb  port.  The  adequate  drivers  should  be  already  installed  (please  refer  to  the

instrument's manual ).

Select the “Send” to device” in the “File” menu, to initiate the layout. 

Please note that uploading a new Layout will replace the previous layout present on the

instrument.

The upload procedure should take a couple of seconds. Once terminated, the changes

appear immediately.

 9 Uploading Airspaces files to the Instrument

The Designer can also be used to upload Airspaces to certain Flymaster instruments,

like for example the Flymaster LIVE. 

At the moment the designer is only compatible with the “Open Air” format. Open Air is a

standard Airspace, and Terrain description language, publicly available, which is almost a

global standard for displaying map information. For more information about the Open Air

format see http://www.winpilot.com/UsersGuide/UserAirspace.asp .

Open Air airspaces files can be find in several websites, for specific countries, regions,

flight  areas,  etc.  In some of  these websites the user can even generate the file  for a

specific  area,  according  to  its  needs.  One  good  example  is

http://www.maddyhome.com/ctr/ .

Once  the  file  with  the  required  airspaces  is  available,  selecting  the  option  “Tools”-

>”Airspaces” will open a dialog box similar to the one of Figure 11.

Clicking the  “Open File”  Button will  allow the user  to pick the desired file,  with  the

airspace information. 
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Figure 11- Airspaces Dialog Box

After selecting the file, all the airspaces data is loaded into the dialog box.

As shown in Figure 12, in the dialog box it is possible to see for each airspace, the

name, class, and also some geometric information. Additionally,  If  the mouse cursor is

positioned over an airspace a small message box appears with extra airspace information.

By default, all the airspaces available on the file are selected. The user can use the

“Check Box” next to each airspace to select, or deselect airspaces When all the desired

airspaces are selected clicking the “Upload” bottom will upload them to the instrument.

ATTENTION:  Each  time a  new set  of  airspaces  is  uploaded  to  the  device,  all  the

previews airspace information is deleted.
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Figure 12- Airspaces Dialog Box
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